#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(\d{2}\/\d{2})(?:\s+(\d{2}\/\d{2}))?\s+(.+?)\s+(\d{4})(?:\s+(\d{4}))?\s+(\d+\.\d{2})$"
Local $sString = " /^(?<transDate>\d{2}\/\d{2})\s+(?<postDate>\d{2}\/\d{2})\s+(?<merchant>[A-Z\s\*\d]+?)\s+(?<webInfo>[A-Za-z0-9\.\/]+)\s+(?<ref1>\d+)\s+(?<ref2>\d+)\s+(?<amount>\d+\.\d{2})$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")