const regex = /^(\d{2}\/\d{2})(?:\s+(\d{2}\/\d{2}))?\s+(.+?)\s+(\d{4})(?:\s+(\d{4}))?\s+(\d+\.\d{2})$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d{2}\\\/\\d{2})(?:\\s+(\\d{2}\\\/\\d{2}))?\\s+(.+?)\\s+(\\d{4})(?:\\s+(\\d{4}))?\\s+(\\d+\\.\\d{2})$', '')
const str = ` /^(?<transDate>\\d{2}\\/\\d{2})\\s+(?<postDate>\\d{2}\\/\\d{2})\\s+(?<merchant>[A-Z\\s\\*\\d]+?)\\s+(?<webInfo>[A-Za-z0-9\\.\\/]+)\\s+(?<ref1>\\d+)\\s+(?<ref2>\\d+)\\s+(?<amount>\\d+\\.\\d{2})\$`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}