import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d{2}\\/\\d{2})(?:\\s+(\\d{2}\\/\\d{2}))?\\s+(.+?)\\s+(\\d{4})(?:\\s+(\\d{4}))?\\s+(\\d+\\.\\d{2})$";
final String string = " /^(?<transDate>\\d{2}\\/\\d{2})\\s+(?<postDate>\\d{2}\\/\\d{2})\\s+(?<merchant>[A-Z\\s\\*\\d]+?)\\s+(?<webInfo>[A-Za-z0-9\\.\\/]+)\\s+(?<ref1>\\d+)\\s+(?<ref2>\\d+)\\s+(?<amount>\\d+\\.\\d{2})$";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}