// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(\d{2}\/\d{2})(?:\s+(\d{2}\/\d{2}))?\s+(.+?)\s+(\d{4})(?:\s+(\d{4}))?\s+(\d+\.\d{2})$").unwrap();
let string = " /^(?<transDate>\\d{2}\\/\\d{2})\\s+(?<postDate>\\d{2}\\/\\d{2})\\s+(?<merchant>[A-Z\\s\\*\\d]+?)\\s+(?<webInfo>[A-Za-z0-9\\.\\/]+)\\s+(?<ref1>\\d+)\\s+(?<ref2>\\d+)\\s+(?<amount>\\d+\\.\\d{2})$";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}