package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\d{2}\/\d{2})(?:\s+(\d{2}\/\d{2}))?\s+(.+?)\s+(\d{4})(?:\s+(\d{4}))?\s+(\d+\.\d{2})$`)
var str = ` /^(?<transDate>\d{2}\/\d{2})\s+(?<postDate>\d{2}\/\d{2})\s+(?<merchant>[A-Z\s\*\d]+?)\s+(?<webInfo>[A-Za-z0-9\.\/]+)\s+(?<ref1>\d+)\s+(?<ref2>\d+)\s+(?<amount>\d+\.\d{2})$`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}