$re = '/^(\d{2}\/\d{2})(?:\s+(\d{2}\/\d{2}))?\s+(.+?)\s+(\d{4})(?:\s+(\d{4}))?\s+(\d+\.\d{2})$/';
$str = ' /^(?<transDate>\\d{2}\\/\\d{2})\\s+(?<postDate>\\d{2}\\/\\d{2})\\s+(?<merchant>[A-Z\\s\\*\\d]+?)\\s+(?<webInfo>[A-Za-z0-9\\.\\/]+)\\s+(?<ref1>\\d+)\\s+(?<ref2>\\d+)\\s+(?<amount>\\d+\\.\\d{2})$';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);