import Foundation
let pattern = #"^(\d{2}\/\d{2})(?:\s+(\d{2}\/\d{2}))?\s+(.+?)\s+(\d{4})(?:\s+(\d{4}))?\s+(\d+\.\d{2})$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #" /^(?<transDate>\d{2}\/\d{2})\s+(?<postDate>\d{2}\/\d{2})\s+(?<merchant>[A-Z\s\*\d]+?)\s+(?<webInfo>[A-Za-z0-9\.\/]+)\s+(?<ref1>\d+)\s+(?<ref2>\d+)\s+(?<amount>\d+\.\d{2})$"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}