#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([a-zA-Z]+( [a-zA-Z]+)+) 3$"
Local $sString = "^[A-C][a-zA-Z0-9]{4}$"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)