import Foundation
let pattern = #"^([a-zA-Z]+( [a-zA-Z]+)+) 3$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"^[A-C][a-zA-Z0-9]{4}$"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)