re = /^([a-zA-Z]+( [a-zA-Z]+)+) 3$/m
str = '^[A-C][a-zA-Z0-9]{4}$'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result