$re = '/^([a-zA-Z]+( [a-zA-Z]+)+) 3$/m';
$str = '^[A-C][a-zA-Z0-9]{4}$';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;