use strict;
my $str = '^[A-C][a-zA-Z0-9]{4}$';
my $regex = qr/^([a-zA-Z]+( [a-zA-Z]+)+) 3$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";