const regex = /^([a-zA-Z]+( [a-zA-Z]+)+) 3$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-zA-Z]+( [a-zA-Z]+)+) 3$', 'gm')
const str = `^[A-C][a-zA-Z0-9]{4}\$`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);