using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zA-Z]+( [a-zA-Z]+)+) 3$";
string substitution = @"";
string input = @"^[A-C][a-zA-Z0-9]{4}$";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}