using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(p\.?\s?[o|0]\.?\s?b\.?([o|0]x)?|post\soffice\sbox)";
string input = @"Pembroke St
Poembroke St
Portsea Boxhill
P O Box
P.O. Box
P O B O X
Pobox
PO BOX
P.O BOX
P0 B0X
Po 8ox
POST OFFICE Box 123
PO Box 123
Post Office st
po box
UNIT 210 2 PEMBROKE ST
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}