import Foundation
let pattern = #"(p\.?\s?[o|0]\.?\s?b\.?([o|0]x)?|post\soffice\sbox)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
Pembroke St
Poembroke St
Portsea Boxhill
P O Box
P.O. Box
P O B O X
Pobox
PO BOX
P.O BOX
P0 B0X
Po 8ox
POST OFFICE Box 123
PO Box 123
Post Office st
po box
UNIT 210 2 PEMBROKE ST
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)