import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(p\\.?\\s?[o|0]\\.?\\s?b\\.?([o|0]x)?|post\\soffice\\sbox)";
final String string = "Pembroke St\n"
+ "Poembroke St\n"
+ "Portsea Boxhill\n"
+ "P O Box\n"
+ "P.O. Box\n"
+ "P O B O X\n"
+ "Pobox\n"
+ "PO BOX\n"
+ "P.O BOX\n"
+ "P0 B0X\n"
+ "Po 8ox\n"
+ "POST OFFICE Box 123\n"
+ "PO Box 123\n"
+ "Post Office st\n"
+ " po box\n"
+ "UNIT 210 2 PEMBROKE ST\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}