# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(p\.?\s?[o|0]\.?\s?b\.?([o|0]x)?|post\soffice\sbox)"
test_str = ("Pembroke St\n"
"Poembroke St\n"
"Portsea Boxhill\n"
"P O Box\n"
"P.O. Box\n"
"P O B O X\n"
"Pobox\n"
"PO BOX\n"
"P.O BOX\n"
"P0 B0X\n"
"Po 8ox\n"
"POST OFFICE Box 123\n"
"PO Box 123\n"
"Post Office st\n"
" po box\n"
"UNIT 210 2 PEMBROKE ST\n")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.