// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(p\.?\s?[o|0]\.?\s?b\.?([o|0]x)?|post\soffice\sbox)").unwrap();
let string = "Pembroke St
Poembroke St
Portsea Boxhill
P O Box
P.O. Box
P O B O X
Pobox
PO BOX
P.O BOX
P0 B0X
Po 8ox
POST OFFICE Box 123
PO Box 123
Post Office st
po box
UNIT 210 2 PEMBROKE ST
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}