use strict;
my $str = 'Pembroke St
Poembroke St
Portsea Boxhill
P O Box
P.O. Box
P O B O X
Pobox
PO BOX
P.O BOX
P0 B0X
Po 8ox
POST OFFICE Box 123
PO Box 123
Post Office st
po box
UNIT 210 2 PEMBROKE ST
';
my $regex = qr/(p\.?\s?[o|0]\.?\s?b\.?([o|0]x)?|post\soffice\sbox)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}