using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*(?=\d{2,3}\sms\b)";
string input = @"2012-02-19 00:11:12,128|DEBUG|Thread-1|@@@ Time taken is 18 ms gf";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}