re = /^.*(?=\d{2,3}\sms\b)/
str = '2012-02-19 00:11:12,128|DEBUG|Thread-1|@@@ Time taken is 18 ms gf'
# Print the match result
str.match(re) do |match|
puts match.to_s
end