const regex = /^.*(?=\d{2,3}\sms\b)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*(?=\\d{2,3}\\sms\\b)', '')
const str = `2012-02-19 00:11:12,128|DEBUG|Thread-1|@@@ Time taken is 18 ms gf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}