$re = '/^.*(?=\d{2,3}\sms\b)/';
$str = '2012-02-19 00:11:12,128|DEBUG|Thread-1|@@@ Time taken is 18 ms gf';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);