import Foundation
let pattern = #"^.*(?=\d{2,3}\sms\b)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"2012-02-19 00:11:12,128|DEBUG|Thread-1|@@@ Time taken is 18 ms gf"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}