using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"^(.*?)(\s[A-Za-z]|[;:])";
        string substitution = @"\1";
        string input = @"Hello a
Hello !world I
Welcome; to";
        RegexOptions options = RegexOptions.Multiline;
        
        Regex regex = new Regex(pattern, options);
        string result = regex.Replace(input, substitution);
    }
}