$re = '/^(.*?)(\s[A-Za-z]|[;:])/m';
$str = 'Hello a
Hello !world I
Welcome; to';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;