const regex = /^(.*?)(\s[A-Za-z]|[;:])/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?)(\\s[A-Za-z]|[;:])', 'mg')
const str = `Hello a
Hello !world I
Welcome; to`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);