package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?)(\s[A-Za-z]|[;:])`)
var str = `Hello a
Hello !world I
Welcome; to`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}