using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:www\.)?\w+\.?\w+\/?\w+)";
string substitution = @"<em><a href=""http://$1"" target=""blank"">$1</a></em>";
string input = @" website.dk/info
website.com
website.dk
www.website.com";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}