import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:www\\.)?\\w+\\.?\\w+\\/?\\w+)";
final String string = " website.dk/info\n"
+ " website.com\n"
+ " website.dk\n"
+ " www.website.com";
final String subst = "<em><a href=\"http://$1\" target=\"blank\">$1</a></em>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}