import re
regex = re.compile(r"((?:www\.)?\w+\.?\w+\/?\w+)")
test_str = (" website.dk/info\n"
" website.com\n"
" website.dk\n"
" www.website.com")
subst = "<em><a href=\"http://$1\" target=\"blank\">$1</a></em>"
result = regex.sub(subst, test_str)
if result:
print(result)