// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((?:www\.)?\w+\.?\w+\/?\w+)").unwrap();
let string = " website.dk/info
website.com
website.dk
www.website.com";
let substitution = "<em><a href=\"http://$1\" target=\"blank\">$1</a></em>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}