use strict;
my $str = ' website.dk/info
website.com
website.dk
www.website.com';
my $regex = qr/((?:www\.)?\w+\.?\w+\/?\w+)/p;
my $subst = '<em><a href="http://$1" target="blank">$1</a></em>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";