#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\{\{\s*[Cc]oord\s*(?:\|(?:[^\{\}]*\{\{[^\{\}]*\}\})?[^\{\}]*)?)\|\s*name\s*=[^\|\{\}]*((?:\|(?:[^\{\}]*\{\{[^\{\}]*\}\})?[^\{\}]*)?\}\})"
Local $sString = "1. {{Coord|a=b|name=foo}}" & @CRLF & _
"2. {{coord|name=foo|a=b}}" & @CRLF & _
"3. {{ Coord" & @CRLF & _
"| name = foo" & @CRLF & _
"| a = b }}" & @CRLF & _
"4. {{coord|name=foo|a={{b}}}}" & @CRLF & _
"5. {{coord|a={{b}}|name=foo}}" & @CRLF & _
"6. {{coord|a={{b|{{c}}}}|name=foo}} <!-- fails -->" & @CRLF & _
"5. {{coord|a=b|name={{foo}}}} <!-- fails -->" & @CRLF & _
""
Local $sSubst = "\1\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)