use strict;
my $str = '1. {{Coord|a=b|name=foo}}
2. {{coord|name=foo|a=b}}
3. {{ Coord
| name = foo
| a = b }}
4. {{coord|name=foo|a={{b}}}}
5. {{coord|a={{b}}|name=foo}}
6. {{coord|a={{b|{{c}}}}|name=foo}} <!-- fails -->
5. {{coord|a=b|name={{foo}}}} <!-- fails -->
';
my $regex = qr/(\{\{\s*[Cc]oord\s*(?:\|(?:[^\{\}]*\{\{[^\{\}]*\}\})?[^\{\}]*)?)\|\s*name\s*=[^\|\{\}]*((?:\|(?:[^\{\}]*\{\{[^\{\}]*\}\})?[^\{\}]*)?\}\})/p;
my $subst = '\\1\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";