const regex = /(\{\{\s*[Cc]oord\s*(?:\|(?:[^\{\}]*\{\{[^\{\}]*\}\})?[^\{\}]*)?)\|\s*name\s*=[^\|\{\}]*((?:\|(?:[^\{\}]*\{\{[^\{\}]*\}\})?[^\{\}]*)?\}\})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\{\\{\\s*[Cc]oord\\s*(?:\\|(?:[^\\{\\}]*\\{\\{[^\\{\\}]*\\}\\})?[^\\{\\}]*)?)\\|\\s*name\\s*=[^\\|\\{\\}]*((?:\\|(?:[^\\{\\}]*\\{\\{[^\\{\\}]*\\}\\})?[^\\{\\}]*)?\\}\\})', 'g')
const str = `1. {{Coord|a=b|name=foo}}
2. {{coord|name=foo|a=b}}
3. {{ Coord
| name = foo
| a = b }}
4. {{coord|name=foo|a={{b}}}}
5. {{coord|a={{b}}|name=foo}}
6. {{coord|a={{b|{{c}}}}|name=foo}} <!-- fails -->
5. {{coord|a=b|name={{foo}}}} <!-- fails -->
`;
const subst = `\1\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);