$re = '/(\{\{\s*[Cc]oord\s*(?:\|(?:[^\{\}]*\{\{[^\{\}]*\}\})?[^\{\}]*)?)\|\s*name\s*=[^\|\{\}]*((?:\|(?:[^\{\}]*\{\{[^\{\}]*\}\})?[^\{\}]*)?\}\})/';
$str = '1. {{Coord|a=b|name=foo}}
2. {{coord|name=foo|a=b}}
3. {{ Coord
| name = foo
| a = b }}
4. {{coord|name=foo|a={{b}}}}
5. {{coord|a={{b}}|name=foo}}
6. {{coord|a={{b|{{c}}}}|name=foo}} <!-- fails -->
5. {{coord|a=b|name={{foo}}}} <!-- fails -->
';
$subst = "\1\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;