import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\{\\{\\s*[Cc]oord\\s*(?:\\|(?:[^\\{\\}]*\\{\\{[^\\{\\}]*\\}\\})?[^\\{\\}]*)?)\\|\\s*name\\s*=[^\\|\\{\\}]*((?:\\|(?:[^\\{\\}]*\\{\\{[^\\{\\}]*\\}\\})?[^\\{\\}]*)?\\}\\})";
final String string = "1. {{Coord|a=b|name=foo}}\n"
+ "2. {{coord|name=foo|a=b}}\n"
+ "3. {{ Coord\n"
+ "| name = foo\n"
+ "| a = b }}\n"
+ "4. {{coord|name=foo|a={{b}}}}\n"
+ "5. {{coord|a={{b}}|name=foo}}\n"
+ "6. {{coord|a={{b|{{c}}}}|name=foo}} <!-- fails -->\n"
+ "5. {{coord|a=b|name={{foo}}}} <!-- fails -->\n";
final String subst = "\\1\\2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}