# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:-\p{Lu}+\b|\s*\([^()]*\)|[,|][^,|\n]+)+$//gm;t' <<< "Berman, PMP, CSM
Adesanya, MBA
Blagrove-Mandley, MSF
Baldwin, M.A. | MBA
Akwaboah-CEH,CASP,CAP,CCSK,SCM,VmWare.
Arif (CCIE SP)
A. Shields, BB, PMP
Young chu, CFA"