using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:-\p{Lu}+\b|\s*\([^()]*\)|[,|][^,|\n]+)+$";
string substitution = @"";
string input = @"Berman, PMP, CSM
Adesanya, MBA
Blagrove-Mandley, MSF
Baldwin, M.A. | MBA
Akwaboah-CEH,CASP,CAP,CCSK,SCM,VmWare.
Arif (CCIE SP)
A. Shields, BB, PMP
Young chu, CFA";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}