const regex = /(?:-\p{Lu}+\b|\s*\([^()]*\)|[,|][^,|\n]+)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:-\\p{Lu}+\\b|\\s*\\([^()]*\\)|[,|][^,|\\n]+)+$', 'gm')
const str = `Berman, PMP, CSM
Adesanya, MBA
Blagrove-Mandley, MSF
Baldwin, M.A. | MBA
Akwaboah-CEH,CASP,CAP,CCSK,SCM,VmWare.
Arif (CCIE SP)
A. Shields, BB, PMP
Young chu, CFA`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);