#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:-\p{Lu}+\b|\s*\([^()]*\)|[,|][^,|\n]+)+$"
Local $sString = "Berman, PMP, CSM" & @CRLF & _
"Adesanya, MBA" & @CRLF & _
"Blagrove-Mandley, MSF" & @CRLF & _
"Baldwin, M.A. | MBA" & @CRLF & _
"Akwaboah-CEH,CASP,CAP,CCSK,SCM,VmWare." & @CRLF & _
"Arif (CCIE SP)" & @CRLF & _
"A. Shields, BB, PMP" & @CRLF & _
"Young chu, CFA"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)