// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:-\p{Lu}+\b|\s*\([^()]*\)|[,|][^,|\n]+)+$").unwrap();
let string = "Berman, PMP, CSM
Adesanya, MBA
Blagrove-Mandley, MSF
Baldwin, M.A. | MBA
Akwaboah-CEH,CASP,CAP,CCSK,SCM,VmWare.
Arif (CCIE SP)
A. Shields, BB, PMP
Young chu, CFA";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}