$re = '/(?:-\p{Lu}+\b|\s*\([^()]*\)|[,|][^,|\n]+)+$/m';
$str = 'Berman, PMP, CSM
Adesanya, MBA
Blagrove-Mandley, MSF
Baldwin, M.A. | MBA
Akwaboah-CEH,CASP,CAP,CCSK,SCM,VmWare.
Arif (CCIE SP)
A. Shields, BB, PMP
Young chu, CFA';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;