re = /(?:-\p{Lu}+\b|\s*\([^()]*\)|[,|][^,|\n]+)+$/m
str = 'Berman, PMP, CSM
Adesanya, MBA
Blagrove-Mandley, MSF
Baldwin, M.A. | MBA
Akwaboah-CEH,CASP,CAP,CCSK,SCM,VmWare.
Arif (CCIE SP)
A. Shields, BB, PMP
Young chu, CFA'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result