package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:-\p{Lu}+\b|\s*\([^()]*\)|[,|][^,|\n]+)+$`)
var str = `Berman, PMP, CSM
Adesanya, MBA
Blagrove-Mandley, MSF
Baldwin, M.A. | MBA
Akwaboah-CEH,CASP,CAP,CCSK,SCM,VmWare.
Arif (CCIE SP)
A. Shields, BB, PMP
Young chu, CFA`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}