import Foundation
let pattern = #".*Copyright . \d{4} b?y? ?(.*)\."#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
</p><div class="copyright">Copyright © 2005 Candy Arrington. Used by permission. All rights reserved.</div>
<div id="nextPrev">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}