# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?:e\.g\.|i\.e\.)(*SKIP)(*F)|\pP+/ \0/g;t' <<< "Blabla, i.e. e.g. blabla..."