// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b(?:e\.g\.|i\.e\.)(*SKIP)(*F)|\pP+").unwrap();
let string = "Blabla, i.e. e.g. blabla...";
let substitution = " \\0";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}